TimeServer 1.80 - Network Time Server
=====================================

Description
-----------

TimeServer is a versatile program that allows you to synchronize
the system clock of multiple computers on a network, with a single 
computer that is synchronized to an atomic clock on the Internet.

TimeServer will synchronize with a server from a configurable address
and will then be available to answer all TIME (UDP, TCP), SNTP and
DAYTIME requests from clients logically 'below' it on the network.

TimeServer can also be configured to broadcast SNTP at a configurable
interval to every client accepting broadcasts on the local network.

TimeServer complies with RFC868(TIME), RFC867(DAYTIME) and RFC1769(SNTP)

In order for TimeServer to synchronize from an atomic clock you must
have a connection of some sort to the Internet.  However, if you don't,
TimeServer can be configured to act as if it is always synchronized
and it will still be possible to synchronize all other computers on
the network to the server's time.

TimeServer is Shareware and will run for 30 days before registration
is necessary.  If you like TimeServer and wish to continue using it
registration is $US20 and can be obtained from our website at
www.haytech.com.au.


Minimum System Requirements
---------------------------

TimeServer will run on Windows 95, 98, ME, NT4 and 2000
TimeServer will run on any machine that is using the above systems


List of Files
-------------

The following files should be present before install
- ReadMe.txt (this file)
- Setup.exe
- TimeServer Control Panel Applet.cpl
- TimeServer Engine.dll
- TimeServer Event Log Interface.dll
- TimeServer User Interface.dll
- TimeServer.exe
- TimeServer.hlp
- TimeServer.service
- Uninstall.exe


Installation Instructions
-------------------------

TimeServer uses it's own install program.  If this didn't come with
the copy of TimeServer you have please visit our website at
www.haytech.com.au to obtain a complete package.

TimeServer Install will ask the path where you want to install TimeServer.
Other options that are avaliable to you are,

- Install as an NT/2000 service

This option allows you to run TimeServer as a service on Windows NT4 
or Windows 2000. TimeServer will then be fully functional before you
log in. This is useful for unattended servers.

- Create a program group in the Start menu

This checkbox will install a program group for TimeServer in the Programs
menu on your Start button. The program group will contain TimeServer
and UnInstall.

- Automatically start TimeServer at startup

This check box will install a shortcut in the StartUp folder so that 
TimeServer will automatically be launched every time your computer 
is started up.

When you are happy with all the details click on "Next" and TimeServer
will be installed.

Next you will be prompted for Time and User Interface settings. This dialog 
and all of its tabs contain full help. Just right-click on the item you 
wish to read about.


Command Line Options
--------------------

TimeServer supports several command line options which allow you to control
it's behaviour as a service.  Because services are only available on Windows NT,
2000, this only applies to TimeServer running on either of those two platforms.

TimeServer.exe: Runs TimeServer normally.

TimeServer.exe -install: Installs TimeServer as a service.

TimeServer.exe -start: Starts the TimeServer service.

TimeServer.exe -stop: Stops the TimeServer service.

TimeServer.exe -uninstall: Uninstalls the TimeServer service.

TimeServer.exe -silent: Use this option in conjunction with any of the other
options to disable error and success message dialogs.  This option is useful
when using these command line options within a batch file.

TimeServer.exe -?: Displays a list of command line options.


Uninstallation / Removal
------------------------

TimeServer also has it's own uninstall program.

Asuming that TimeServer Install was used, TimeServer Uninstall will
completly remove files, shortcuts and registry entries installed
for Timeserver.  

TimeServer Uninstall can be accessed from 'Add/Remove Programs' in Control
Panel, or opened directly from the TimeServer folder in the Start Menu.

Uninstall will not, however, remove the registration code.  

If you change your mind further down the track and decide that you wish 
to reinstall TimeServer your registration will still work.


Copyright and Contact Details
-----------------------------

Mount Hay Technology
25 Livingstone St
Lawson NSW 2783
Australia

Phone +61-2-47591247
FAX   +61-2-47591095

website www.haytech.com.au
E-mail enquries@haytech.com.au
