<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
 <HTML><HEAD><TITLE>Rebuilding a failed drive</TITLE>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1"><BASE
target=_top><LINK href="basicpg.css" rel=stylesheet>
<META content="MSHTML 6.00.2600.0" name=GENERATOR></HEAD>
<BODY text=#000000 vLink=#333399 aLink=#0000ff link=#0000ff bgColor=#ffffff>
<H1>Rebuilding a failed drive</H1>
<P>A physical drive is marked failed when there is a loss of communication
between the controller and the physical drive. This can be caused by any of the
following: </P>
<UL>
  <LI>An improperly connected cable, physical drive, or controller<BR><BR>
  <LI>Loss of power to a drive <BR><BR>
  <LI>An improperly assembled SCSI channel in an unsupported configuration
  <BR><BR>
  <LI>A defective cable, backplane, physical drive, or controller <BR><BR>
  <LI>Connecting unsupported SCSI devices (such as tape drives or CD-ROM drives)
  to the same SCSI channel used for an pool </LI></UL>
<P>In each case, after the communication problem is resolved, a rebuild
operation is required to reconstruct the data for the device in its disk pool.
The controllers can reconstruct RAID level-1, level-5,
level-10, and level-50 logical devices. They
cannot, however, reconstruct data stored in RAID level-0 logical devices because
RAID level-0 is not redundant. If an pool contains only RAID level-0 logical
drives, the logical devices in the pool are marked failed and the logical devices contain damaged data. You cannot rebuild the logical devices. You must
correct the cause of the failure or replace the physical drives; then, you must
restore your data.
<P>To prevent data-integrity problems, the controllers set the RAID
level-0 logical devices in the affected pool to blocked during the rebuild
operation for RAID level-1 or RAID level-5. After the rebuild operation is
completed, you can unblock the RAID level-0 logical devices and access them once
again. Remember, however, that the RAID level-0 logical devices contain damaged
data.
<H2>More information</H2>
<UL>
  <LI><A href="cfixddd1.htm">Recovering from failed drives</A>
  <li><a href="cfixddd2.htm">Rebuilding a hot-swap drive</a></li>
  <LI><A href="arbddd.htm">Manually rebuilding a failed drive</A>
  <LI><A href="craid0.htm">RAID level-0</A>
  <LI><A href="craid1.htm">RAID level-1</A>
  <LI><A href="craid5.htm">RAID level-5</A>
  <LI><A href="craidx0.htm">RAID level-x0</A> </LI></UL>
<DIV align=center>
<HR>
<A href="gportal.htm">Glossary</A> | <A href="menutoc.htm">Contents</A></DIV>
<P>&nbsp;</P>
<P align=right>x-1025-HSM-00-05-EN </P></BODY></HTML>
