Troubleshooting

Question: How do I recover from a failed update when the software repository becomes unavailable while the update is performed in HP Systems Insight Manager?

Answer: If the update task uses a software version criteria, execute the task again. The update will start over. Furthermore, the Smart Components that are deployed only install if supported by the target servers.

Use the task log to examine the target systems and determine where the update failed.

Question: The software update feature in HP Systems Insight Manager does not locate any repositories. How can this be corrected?

Answer: Verify the Discovery settings and ensure that the IP range specified does not exclude the selection of available repositories. Also, for a repository to announce itself as such to HP Systems Insight Manager, ensure that all repositories are managed by Version Control Repository Manager. While it is not necessary, it is useful to set up a Version Control Repository Manager on a system before you run Discovery in HP Systems Insight Manager for the first time. Make sure that the Version Control Repository Manager trusts  HP Systems Insight Manager. For more information about setting up trust relationships refer to "Setting up Trust Relationships" in the   HP Systems Insight Manager User Guide and in the Understanding  HP Systems Insight Manager Security White Paper located on the Management CD.

Question: During the automatic update, I received the following error: “The automatic updated failed because an error occurred while retrieving the download site catalog.” The error message referenced an error for the catalog.xml file and an error code 12007, 12015, and so on.  What does this mean?

Answer: While the automatic update process was in progress, the Version Control Repository Manager was unable to connect to the website.

HP recommends that you:

Question: I installed Version Control Repository Manager and configured it for automatic updates.  Its log says the update succeeded, but there are no files in the repository.  Why is this happening?

Answer: The Version Control Repository Manager only downloads software based on the operating system of servers that have a Version Control Agent configured to use that Version Control Repository Manager.  You must have at least one server with a Version Control Agent installed and configured to use the Version Control Repository Manager that is doing the automatic update, which can be the same server.  In addition, the Version Control Agent must access the Version Control Repository Manager at least once every 30 days to keep the operating system information from aging out of the Version Control Repository Manager download list.

HP recommends that you:

  1. Install the Version Control Agent on the appropriate servers.

  2. Configure the Version Control Agent to use the Version Control Repository Manager.

When using HP Systems Insight Manager, be sure the servers with the Version Control Agent are included in its discovery list, and software status polling is scheduled to occur with a frequency no greater than 30 days.

Question: The job of the Software Version Status Polling tasks in HP Systems Insight Manager is to retrieve a list of installed software and firmware from systems and obtain the software status from Version Control Agent on those systems. Why must I specify a repository when setting up this task? Does it matter which repository I choose?

Answer: HP Systems Insight Manager sends the selected Version Control Repository Manager a list of all the software versions in sorted order. This process is necessary so that HP Systems Insight Manager can properly handle queries that include software version comparisons (for instance, return systems with HP Array Driver < Version 5.10.0.0). It is not important which repository is chosen here—the Version Control Repository Manager can return a sorted list of versions for a component even if that component does not exist in the repository. However, it is generally a good idea to choose a repository with the most complete set of software.

Question: The group configuration feature in HP Systems Insight Manager denies access to the source system for security reasons. How is this corrected?

Answer: HP Systems Insight Manager implements security to ensure that access to management information is available only to authorized users. This security relies on security setting between HP Systems Insight Manager with managed systems. HP Systems Insight Manager will deny access if the trust relationship between HP Systems Insight Manager and the source system Management HTTP Server is not configured correctly. To correct this problem, HP suggests the following procedure:

  1. Navigate to http://devicename:2381.

  2. Click the Settings tab. The Settings page is displayed.

  3. Click the Options link. The Options page is displayed.

  4. Click Configuration Options.

  5. Click Trust Mode. Correct the configuration.

For more information regarding Trust Relationships, refer to "Setting up Trust Relationships" in the HP Systems Insight Manager User Guide.

Complete information on the security implemented by the management system (where the Version Control Repository Manager is installed) and the managed systems (Management HTTP Server) is available in the "Security" white paper, on the HP website at

http://www.hp.com/servers/manage

Question: Can I use the software/firmware criteria in HP Systems Insight Manager to tell which version of a Support Pack is installed?

Answer: Generally, ProLiant Support Packs cannot be used for comparison when developing a software update query. However, if you must compare ProLiant Support Packs, use the following guidelines when selecting ProLiant Support Packs to compare:

It is unlikely that all of the components in a ProLiant Support Pack will be installed on any system. This issue will cause most queries that include Support Pack software criteria to return no systems.

Question: Why did the Version Control Agent encounter an error while obtaining the software and firmware inventory?

Answer: The Version Control Agent requires the Foundation Agent 5.30 or later. You must install SNMP and Foundation Agent. You can download the agent at http://www.hp.com/servers/manage.

Question: Should the Version Control Repository Manager be installed before running Discovery in HP Systems Insight Manager, and if so, why?

While it is not essential, it is a good idea to install a Version Control Repository Manager before running Discovery. Be sure that this repository trusts HP Systems Insight Manager. Refer to “Setting up Trust Relationships” in the HP Systems Insight Manager User Guide for more information on trust relationships.

It is a good idea to install a Version Control Repository Manager is so that the Software Version Status Polling task can properly sort the versions of software retrieved from systems. If you do not set up a repository before running Discovery, then the versions will be sorted when a software criteria query is set up for the first time.

Question: Why is it that when I query for systems with HP Insight Management Agent for Windows in HP Systems Insight Manager, I get only the Windows 2000 systems back and not Windows NT?

Answer: Even though you choose a component that is supported for both Windows NT and Windows 2000, the query will only return the systems that match the operating system tree from which you chose the component when you created the query. In this example, if you chose the HP Insight Management Agent for Windows from the Windows 2000 branch of the criteria tree, then only Windows 2000 systems are returned. If you want systems from both Windows 2000 and Windows NT, choose the HP Insight Management Agent for Windows from the Windows 2000 and Windows NT branches.

Question: One of the three items I was trying to install from HP Systems Insight Manager failed to download from the repository, the other two items, which downloaded properly, did not install.

Answer: If any items fail to download from the repository, the Version Control Agent will not attempt to install any of the items.

Question: I set up a task to notify me using email when a software update task completed in HP Systems Insight Manager, but when the event arrived, not all of the software was completely installed.

Answer: The software update task sends the Version Control Agent on each target system a command to install the specified components. After the install command has been sent to the last system, the software update task completes, and the completion event is sent. However, at this time, some of the systems may still be in the process of downloading components and installing them.

Question: What capabilities do I get from the Version Control Agent alone?

Answer: The Version Control Agent provides a list of the HP system software and firmware installed on the local server. For the Version Control Agent to provide version control and software distribution functionality, it must be configured to refer to a Version Control Repository Manager.

Question: Why do I see a reboot required (Status 2) in the Version Control Agent Log but not in the Install Log?

Answer: The Version Control Agent Log page contains information logged by the Version Control Agent during its operation. The Version Control Agent Log is often informational when you are trying to troubleshoot a problem, such as why a specific task failed.

The Log page contains information logged by the component setup program.

Question: Why do some of my components not install and report in the log as failed, although the hardware exists on my server and requires the update?

Answer: Some HP components are not written to support silent installation, such as HP NIC drivers for Windows NT, which is an installation that requires user intervention. The Version Control Agent can only install components that are written for silent installation. The following components currently do not support silent installation:

If silent installation is not supported:

  1. View the Version Control Agent log and determine which component failed.

  2. Access the failed system, and browse to the Version Control Repository Manager repository from that system.

  3. Browse to the Catalog and identify the component.

  4. Click on the component. The Component Details page is displayed.

  5. Click the link associated with the component at the top of the Component Details page to download the failed component.

  6. Save the component to the system.

  7. Install the component manually.

In the event components fail because they are not signed by Authenticode technology or have not cleared the Microsoft Windows logo testing, check the target system for messages.

Question: If these components do not or will not install without user intervention or silently, why does the Version Control Agent report Failed to Install?

Answer: At the current time, the Version Control Agent does not differentiate between silent and non-silent components.

Question: Does HP have any intention of disabling the Install icon on those components that do not install silently or without user intervention in future releases?

Answer: Yes.

Question: Why can’t I install or update the Version Control Repository Manager using the Version Control Agent? I receive an Unable to install the Microsoft XML Parser 3.0 (1603) error.

Answer: You are attempting to install the Version Control Repository Manager with the Version Control Agent, whose service does not have administrative privileges.

Perform the recommended changes only on servers running both the Version Control Agent and Version Control Repository Manager:

  1. Launching the Services program.

  2. Right-click the Version Control Agent service.

  3. Select Properties.

  4. Select the Log On tab.

  5. Click This account.

  6. Enter the name of or browse to a user with administrative privileges using Browse.

  7. Click OK to save the changes.

You can now install and upgrade the Version Control Repository Manager using the Version Control Agent.

Question: Why do some of the components display in the inventory for hardware that is not physically located on my server?

Answer: This issue is caused by a conflict between SmartStart and the Version Control Agent and might display with Yellow status icons in the Latest Version and Support Pack columns.

SmartStart installs all components, specifically storage components, for hardware, regardless of the physical location of hardware on the server, for example:

The inventory for these components might display with yellow status icons, stating an upgrade is needed and available, which occurs when the Version Control Repository Manager configured on the Version Control Agent is cataloged with newer versions of these components.

For example, if your server is configured with components from SmartStart 5.2 and the catalog of your Version Control Repository Manager contains new SmartStart 5.3 components, the inventory of the Version Control Agent displays the preceding items with yellow status icons. You cannot upgrade these components because the physical hardware does not exist on the server or allow the status icons to display with a green icon reporting the components are current. The overall status also continues to display with a yellow icon because the Version Control Agent is reporting components that need updating.

You can create a Custom Software Baseline excluding these components and configure your Version Control Agent to use it as its Reference Support Pack. This option allows the Support Pack Version column to exclude these components during its version comparison, which allows your overall status to display with a green icon stating the inventory is current. However, the Latest Version column continues to display with yellow icons for these components.

This solution should only be applied to those servers without the storage hardware physically installed.

This problem will be corrected in future releases of the Version Control Agent.

Question: Why isn't some of the software installed on the system shown in the Software Inventory of the Version Control Agent?

Answer: The following components do not appear if you have HP Insight Management Agents 5.20 or earlier installed on the system:

These components will be displayed in the Software Inventory of the Version Control Agent if you install HP Insight Management Agents 5.30 or later.

Question: When I copy the files from a Support Pack into the repository manually, I might not see all of the new components listed on the Catalog page. What can I do to see these files?

Answer: When you copy files into the repository manually without using the Version Control Repository Manager, the repository may need to be rescanned and the catalog rebuilt. For more information regarding copying files into the repository manually, refer to Updating the Repository Manually from the SmartStart CD. For more information regarding rescanning the repository, refer to Rescanning the Repository and Rebuilding the Catalog.

Question: I have just completed a new Version Control Agent for Linux installation, but the Version Control Agent service does not start. How can I start the service?

Answer: First, try to start the Version Control Agent manually using the following command:

# /etc/init.d/hpvca start

If the Version Control Agent still does not start, try the following commands:

# rm -rf /var/spool/compaq/wbem/cache

# /etc/init.d/hpvca start

Question: The Version Control Agent for Linux is unable to set or configure the repository username and password from a group configuration task issued by HP Systems Insight Manager even though the user name and password are correct. Why is this happening?

Answer: The Version Control Agent for Linux does not support extended characters in the password. Be sure that the Windows repository system does not have extended characters in the password.

Question: After downloading a ProLiant Support Pack for Linux from the HP website, I am getting the following error message when trying to install the Version Control Agent for Linux: Unable to retrieve “The Smart Component, hppldu-1.0.2-5.tar-gz, could not be retrieved from the Version Control Repository Manager on Server (IP Address). Download stopped”. Why am I getting this error?

Answer: The ProLiant Support Packs for Linux 7.00 that were delivered on SmartStart CD Release 7.00 and Software Maintenance CD Release 7.00 to the repository are not affected and installed properly.

HP recommends that you:

  1. Download the Red Hat Enterprise Linux 3 ProLiant Support Pack 7.00 to the same repository folder the ProLiant Support Pack with the missing files is located.

  2. Proceed with the ProLiant Support Pack installation using the Version Control Agent for Linux.

Question: I have installed the Version Control Agent using GNOME file manager, but the Version Control Agent cannot be configured or the installation appears to be hanging. The same thing happens on the KDE file manager. Why don’t I have the option to configure the Version Control Agent on GNOME and KDE file managers?

Answer: The Version Control Agent installation is not supported on GNOME or KDE file manager. The Version Control Agent installation can occur in two ways:

Question: I have changed the Version Control Repository Manager settings in the Version Control Agent, but when I click Change Agent Settings, the old Version Control Repository Manager configuration is displayed. Why is the old information still displaying?

Answer: The Password Manager in Mozilla can remember the old information, and it automatically inserts the information for you when you click Change Agent Settings.

HP recommends the following workaround:

  1. From the Mozilla menu bar, click Tools>Password Manager>Manage Stored Passwords. The Password Manager dialog box is displayed.

  2. Select the Passwords Saved tab.

  3. Select the Site that you want to remove, and click Remove.

  4. Click Close to save your settings and close the dialog box.

Question: What are the Windows 2000 Events for the Version Control Agent?

Answer: The following table shows a listing of NT events that are applicable to the Version Control Agent.

Event ID

Facility

Severity

Text

28

Application

Informational

The installation task succeeded. Version Control Agent Log URL.

53

Application

Informational

The configuration task succeeded. Version Control Agent Log URL

60

Application

Informational

Started the Version Control Agent (normal startup).

65

Application

Informational

The Version Control Agent Win32 service was stopped

208

Application

Error

The installation task failed. Version Control Agent Log URL:

503

Application

Error

The configuration task failed. Version Control Agent Log URL

604

Application

Error

The Version Control Agent Win32 service could not be started successfully.

Question: What are the Windows NT/Windows 2000 Events for the HP Version Control Repository Manager?

Answer: The following table lists the Windows NT/2000 event for the Version Control Repository Manager.

Event ID

Facility

Severity

Text

4098

Application

Informational

Version Control Repository Manager failed to start.