The general command line syntax for the HP Smart Update Manager is:

hpsum [/h[elp]] [/f[orce]] [/g (downgrade)] [/e (rewrite)]
[/m[utual])] [/r[eboot]] [/reboot_message "reboot message"]
[/reboot_delay timeout_in_seconds] [/reboot_always] [/s[ilent]]
[/c <component_to_install>] [/group] [/bundle] [/allow_update_to_bundle] 
[/dryrun] [/continue_on_error <error>] [/override_existing_connection] 
[/user <username>] [/passwd <password>] [/target <netAddress>]

Using HP Smart Update Manager with HP BladeSystem C-Class Onboard Administrator 
or remote hosts requires the user ID, password and the target server IP address 
or DNS name to log in.

NOTE: All arguments and information enclosed in brackets are optional. The 
      arguments may be prefixed with either a '-' or '/' character. These 
      examples show only the '/'.

If no command line arguments are executed on the command line, the component 
GUI appears.

Command line argument 		Description
/h[elp] or /?			This argument displays command line Help
				information.
				
/f[orce] 			This argument enables you to override or 
				downgrade an existing installation of a given 
				component.
				
/g or /downgrade 		This argument enables you to downgrade to an 
				earlier version of firmware for multi-target 
				devices such as hard drives and array 
				controllers. (Applies to firmware only.)
				
/e or /rewrite 			This argument enables you to rewrite the same 
				version of firmware to a device in the event 
				that the firmware has been compromised, or to 
				confirm that the version has been correctly 
				installed. This argument must be used with the 
				/force option or it will be ignored. (Applies 
				to firmware only.)
				
/m[utual] 			This argument informs the firmware flash engine 
				to flash the firmware if the device to be 
				flashed is in a shared storage environment. If 
				the device to be flashed is in a shared storage 
				environment and the -m option is not passed, 
				the component installation will fail. (Applies 
				to firmware only.)

				
/r[eboot] 			This argument causes the server (or host 
				server in a remote installation) to reboot if 
				the following conditions are met:
				* The /reboot option has been selected or given 
				  as a command line argument.
				* All components selected for installation were
				  successfully installed.
				* At least one of the components installed 
				  required a reboot to complete its 
				  installation.
				  
/reboot_message "message" 	This argument displays the specified reboot 
				message on remote consoles connected to the 
				server to be rebooted. This argument must be 
				used with the /reboot option or it will be 
				ignored.
				
/reboot_delay timeout_in_secs 	This argument delays the reboot of the server 
				for timeout_in_seconds seconds. This argument 
				must be used with the /reboot option or it will 
				be ignored. Acceptable values are between 15 
				and 3600. The default timeout value is 15 
				seconds for Windows and 60 seconds for Linux.
				
/reboot_always		 	This argument forces the server to reboot if 
				the following conditions are met:
				* The /reboot_always option has been selected 
				  or given as a command line argument.
				* All components selected for installation were
				  successfully installed.
				  
/s[ilent] 			This argument causes the installation to run 
				silently with no GUI or console output. All 
				data is written to the log file. Any prompts 
				use the default option and continue the 
				installation without user input. If a component 
				requires input before installation, such as
				configuration information, the installation of 
				the component fails and an error message is 
				written to the log file.
				
/c <component_to_install> 	This argument specifies a single component to 
				install. You can specify multiple /c options 
				and components. The components are installed 
				in the order provided unless dependencies 
				between components require installation in a 
				different order. If so, the utility changes 
				the installation order based on the component 
				dependencies to ensure the successful 
				installation of as many components as possible. 
				
/group <HPSUMgroup>		This argument specifies an already defined 
				group name in the HP Smart Update Manager 
				internal database where the group hosts reside.
				
/bundle <bundlename>		This argument specifies the name of the bundle 
				to be installed and can be specified multiple 
				times.  

/allow_update_to_bundle		This argument allows the user to install newer 
				versions of components defined in a PSP or 
				firmware bundle if they exist.  This parameter 
				will allow these components to replace the 
				older versions of the same component that may 
				have shipped with the bundles.  

/dryrun				This argument simulates the installation for a 
				test run. Nothing is installed. 

/continue_on_error <error>	This argument causes the installation to 
				continue and ignore errors. Currently, only the 
				<error>=ServerNotFound is supported.  The 
				ServerNotFound option can be used to bypass 
				inactive or unavailable remote hosts when 
				deploying firmware or software to multiple 
				remote hosts at the same time.

/override_existing_connection	This argument is used to define the behavior 
				when a remote thost is found to already have 
				an existing HP Smart Update Manager session in 
				progress.  The /override_existing_connection 
				overrides the session in progress and 
				re-initializes the installation framework on 
				the remote host.

/user <username>		This argument enables you to log in to HP 
				BladeSystem C-Class Onboard Administrator or 
				remote hosts with this user ID.

/passwd <password>		This argument enables you to use this password 
				for the userid specified in the /user parameter. 
				The password is used to login to remote host and
				HP BladeSystem C-Class Onboard Administrators.

/target <netAddress>		This argument is the IP address or the DNS name 
				of a HP BladeSystem C-Class Onboard 
				Administrator or remote host. When two 
				Onboard Administrators are in an enclosure, 
				this argument should be the active Onboard 
				Administrator.

Return codes

HP Smart Update Manager has consolidated the return codes from Linux and 
Windows components into a new, enhanced return code mapping. These return 
codes determine the status of the component installation. You can also use 
return codes in a script to control the execution of the script and determine 
any required branching.

Return code			Value	Text
SUCCESS_NO_REBOOT		  0	The installation was successful.
SUCCESS_REBOOT			  1	The installation was successful, but a 
					reboot is required.
SUCCESS_NOT_REQUIRED		  3	The component was current or not 
					required.
FAILURE_GENERAL			 -1	A general failure occurred. See the 
					error log for details.
FAILURE_BAD_PARM		 -2	A bad input parameter was encountered.
FAILURE_COMPONENT_FAILED	 -3	The installation of the component 
					failed.


